Points losing power
Results 1 to 5 of 5
  1. #1
    Junior Member Joradfo's Avatar
    Join Date
    Nov 2020
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Points losing power

    I have a roper 18t with an onan b48m. I recently put the brass floats in with the helper spring of course. It ran well for a few days after the install however now it keeps stalling. so I started at the basics and took the points cover off and found while I'm cranking I don't see a spark there, then it gets spark and fires up roght away. while its running it seems to loose spark again and stalls. It will crank for a while with no spark at the points before it seems to fire.

  2. Remove Advertisements
    CaseColtIngersoll.com
    Advertisements
     

  3. #2
    Senior Member Gordy's Avatar
    Join Date
    Apr 2011
    Location
    Maple Lake, MN
    Posts
    2,435
    Thanks
    3,075
    Thanked 1,372 Times in 886 Posts
    Could be a dirty, corroded, or even loose wire connection in the ignition system. That's where I would start. Coils and condensers and ignition switches can do strange things when going bad. Running a test lead from battery + to coil + may help narrow the problem down. Good spark would indicate a problem in the wiring before the coil, if the problem persists that would indicate coil, points or condenser is the problem.


    Gordy

  4. #3
    Senior Member sdunt's Avatar
    Join Date
    Apr 2017
    Location
    Central Illinois - Bloomington
    Posts
    1,644
    Thanks
    107
    Thanked 1,172 Times in 620 Posts
    If you are saying that you see sparks at the points, then the condenser is bad. its job is to protect the points from arcing.

  5. The Following User Says Thank You to sdunt For This Useful Post:

    ROCKLAND VALLEY (11-23-2020)

  6. Remove Advertisements
    CaseColtIngersoll.com
    Advertisements
     

  7. #4
    Junior Member Joradfo's Avatar
    Join Date
    Nov 2020
    Posts
    7
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Ok interesting. This is my first machine with points so I should never really see a spark there while its running?

  8. #5
    Dealer myerslawnandgarden's Avatar
    Join Date
    Jan 2011
    Location
    Hinckley, IL
    Posts
    1,111
    Thanks
    76
    Thanked 707 Times in 425 Posts
    Joradfo,

    As sdunt mentions there should be little or no arcing at the points when running. For top adjust breaker point boxes the condenser is p/n 312-0246: https://www.casegardentractorparts.com/31caon.html

    Bob

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •